Moin. apt-get (debian sarge) hat mir beim letzten Update postgresql von 7.2 auf 7.3 mit geupdated. Leider hat der Dump in die Datei db.out, wie in der Systemmail versprochen, nicht funktioniert. Nun kriege ich die Daten aus dem Verzeichnis /var/lib/postgres/preserve/data.7.2.1-2.save nicht wiederhergestellt, da die Binaries und/oder conf-Dateien zwischen 7.3 und 7.2 irgendwie inkompatibel sind. Ich habe auch die Libs für 7.2 wieder per Hand nach /usr/lib kopiert, bin aber immer noch nicht weiter. Hat jemand ne Idee ? Wie kann ich notfalls wieder auf 7.2 downgraden? Es sind keine wichtigen Daten, nur ein CD/LP-Archiv, allerdings wäre es sehr mühsam, die Daten per Hand neu einzurichten/abzugleichen (zumal sie ja sicher noch da sind). Die System-Mail nach Update enthielt folgenden Fehler: -----------------------------8<------------------------------------------- Stopping and restarting the postmaster /var/lib/postgres/dumpall/7.2/postmaster -D /var/lib/postgres/data -p 5431 -o -d0 DEBUG: database system was shut down at 2003-06-09 11:00:17 CEST DEBUG: checkpoint record is at 0/EBC7C38 DEBUG: redo record is at 0/EBC7C38; undo record is at 0/0; shutdown TRUE DEBUG: next transaction id: 129721; next oid: 17206 DEBUG: database system is ready Dumping the database to /var/lib/postgres/db.out /var/lib/postgres/dumpall/7.2/pg_dumpall connected to template1... /var/lib/postgres/dumpall/7.2/psql: error while loading shared libraries: libpq.so.2: cannot open shared object file: No such file +or directory Finding the default encoding /var/lib/postgres/dumpall/7.2/psql: error while loading shared libraries: libpq.so.2: cannot open shared object file: No such file +or directory -----------------------------8<------------------------------------------- Die Libs habe ich ihm dann per Hand wieder untergejubelt. Der neue Postmaster ist angehalten. Ich rufe auf: -----------------------------8<------------------------------------------- postgres@rory:~$ /var/lib/postgres/dumpall/7.2/postmaster -D /var/lib/postgres/preserve/data.7.2.1-2.save/ -p 5431 -o -d0 FATAL 1: 'DATESTYLE' is not a valid option name postgres@rory:~$ -----------------------------8<------------------------------------------- Mit den alten Config-Files in /etc/postgresql hat es auch nicht funktioniert. -- Gruß, Lars
Teilnehmer (3)
-
Andre Landwehr
-
Christian Ordig
-
Lars Boeker