GCC: ChangeLog, 1.6 -> 1.7

Jan-Benedict Glaw jbglaw at dvmwest.gt.owl.de
Wed Aug 18 10:52:39 CEST 2004


Update of /mnt/vax-development/CVS_Repository/gcc/gcc/java
In directory mail:/mnt/vax-development/local_work/work-jbglaw/local-cvs/gcc/gcc/java

Modified Files:
	ChangeLog 
Log Message:
- - - -- -- A U T O M A T I C   C H E C K I N -- -- - - -
	* tree.h (struct tree_decl): Add gimple_formal_temp.
	(DECL_GIMPLE_FORMAL_TEMP_P): New.
	* gimplify.c (pop_gimplify_context): Clear it.
	(lookup_tmp_var): Set it, if is_formal.
	(gimplify_init_constructor): Use rhs_predicate_for for COMPLEX.
	Use is_gimple_val for VECTOR.  Simplify return value.
	(gimplify_save_expr): Use and set DECL_GIMPLE_FORMAL_TEMP_P.
	(gimplify_expr): Likewise.
	* tree-gimple.c (is_gimple_formal_tmp_rhs): Rename from
	is_gimple_tmp_rhs for clarity.  Update all callers.
	(is_gimple_reg_rhs): Simplify logic.
	(is_gimple_formal_tmp_var): Rename from is_gimple_tmp_var for
	clarity; use DECL_GIMPLE_FORMAL_TEMP_P.
	(is_gimple_formal_tmp_reg): Similarly.
	* tree-gimple.h: Update decls.
	* tree-ssa-copyrename.c (copy_rename_partition_coalesce): Use
	DECL_IGNORED_P, not DECL_ARTIFICIAL.  Tidy formatting.
	* tree-ssa-live.c (var_union, type_var_init): Likewise.
	java/
	* java-gimplify.c (java_gimplify_expr): Move '2' handling into
	default case.  Treat '<' similarly.  Update for
	is_gimple_formal_tmp_var name change.
	testsuite/
	* gcc.dg/20040206-1.c: XFAIL.


More information about the VAX-Toolchain-CVS mailing list